Creating a Site in 5 Simple Steps

Cesar Perez

Introduction

We here at CoffeeCup Software have received numerous questions about how to go about creating a basic site with the HTML Editor.  To help all our users and anyone else interested, we’ve created this handy guide.  Part of this lesson is to give you an example with which to follow along.

In the interest of simplicity I’ll be breaking down the creative process into 5 steps:

1. Choosing a Layout

a. Layout Information

b. HTML for Beginners Layouts

c. Working With a Layout

d. Configuring the Program Settings

2. Recreating the Index

a. Header Section

b. Content Section

i. Updates/Revisions

ii. Formatting the Section

iii. Industry News

iv. Download this Website

v. Adding Images

c. Navigation Section

d. Extra Section

e. Footer Section

3. Recreating the Getting Started Page

a. New Layout

b. Copying Header, Footer, and Navigation

c. Content Section

d. Extra Section

4. Styling the Website

a. Header Section Colors

b. Footer Section Colors

c. Navigation and Extra Section Backgrounds

d. Other Custom Styles

5. Saving, Testing and Uploading

Be sure to download the accompanying website files to follow along with.  You can download the file from (final_url_here) and unzip it to your hard drive.  Be sure to place it somewhere that you’ll be able to find it easily.

Step 1 – Choosing a Layout

Once you have an idea, you’ll need to know how you want to organize the site (both physically and logically).  This includes the types of sections your site will contain as well as how the layout will be planned.

Choosing a layout for your site is arguably the most important design step, assuming you have an idea of where you want to take the site, as it lays the groundwork from which the rest of the design stems.  As with getting your idea, you don’t need to know every detail just yet, but the more you have in mind the better off you’ll be in the end.

There are various techniques you can use to perform this step, and the validity of each is debatable, so I’ll leave it to the reader to discover them all.  My favorite (as well as many other designers from my research) is still pen and paper.  There is something to be said about being able to quickly and easily sketch a few different ideas just to get them out of your head and see what they’ll look like.

There are a few traditional layouts that can serve as catch-alls, and they’re safe because they have already proven on numerous occasions that readers easily receive the information they contain.  Newspapers (and news sites) tend to have a three-column layout – as studies have shown readers expect this.  Most blog sites tend towards a two-column layout with the main content on one side (left or right) and a sidebar of related links opposite.  Then there are sites that purposefully deviate from the established norms, but almost always as a conscious effort to do something different and groundbreaking.

HTML for Beginners layouts

Because HTML for Beginners needs to look more professional (since it will be used as a reference source) I’ve only sketched two different layouts, a two-column layout with header and footer, and a three-column layout with header and footer.

Fig. 1 – Initial HTML sketches.

Both are equally valid for the purposes of this site, but the three-column layout provides the opportunity to link to relevant content based on what the visitor is currently looking at.  If the page displays the basic tags for creating tables, the sidebar can be used to provide showcases, examples, or even links to other tutorial sites.  It’s also a great area to place ads that may be of interest to design firms or individuals, and that keeps with the “professional” feel I want to give this.  In fact, we can keep the homepage with the three-column layout and use the two-column layout for interior pages to provide a larger area for content.

Working with a Layout

Now that we have a better idea of the kind of layout we want to use, we can start working with a digital version.  The HTML Editor is bundled with 40 layout templates you can use to get started, including the models we’ve discussed so far.  You can also see what the other templates look like with the thumbnail previews provided.

Select File > New from Layout…

One thing I haven’t discussed yet is the difference between a fixed and liquid layout, which you can see is a large part of the layout decision process.  A fixed layout (as the name implies) uses a fixed number of pixels to determine various element widths within the design.  This can be applied to the overall width, or just to each section of the page.  If you’ve ever seen a website where only part of the browser window is filled, while the rest only displays the background, then you’ve seen a fixed-width layout.

A liquid layout allows various sections (or the entire design as a whole) to fill the screen, like liquid filling a container.  This is probably the most familiar and most obvious choice for a layout.  Why wouldn’t you want to fill up the entire browser window with your site?  That answer gets a little complicated and can involve usability, accessibility, and a host of other factors which may or may not be detrimental to the site.  Liquid layouts are generally harder to code and take longer to test, but the advantages of flexibility can outweigh these others concerns (if it fits the site).

There are several different choices to use for our three-column homepage:

· Liquid, secondary columns fixed-width (n.13)

· Liquid, three columns, hybrid widths (n.19)

· Liquid, three columns, hybrid widths (n.20)

· Three fixed columns (n.07)

· Three percentage columns (n.01)

Fig. 2 – Liquid, Secondary Columns Fixed-Width (n.13) Layout screenshot

We can also see the interior layout as:

· Two columns fixed (n.34)

· Two columns liquid, side fixed (n.24)

· Two percentage columns (n.26)

Fig. 3 – Two Columns Liquid, Side Fixed (n.24) Layout screenshot

Each set of layouts presents the same general structure, with the variations being a fixed or liquid width.  The choice that makes the most sense for our site is probably the Liquid, Secondary Columns Fixed-Width, as this will provide the most efficient use of the screen’s real estate.  To follow along with the initial layout, but still provide variation, we can use the Two-columns liquid, side fixed layout for our interior pages.

Now that we know which two layouts we’ll be using, we can open one.  Let’s start with the three-column layout (n.13) first, since this will be our homepage.

Configuring the Program Settings

Now that we have a file open, we can change some of the program options to help us work a little easier.  Select Tools > Preferences…

Fig. 4 – Preferences Window

We’ll check “Auto Spell Check on by Default” and “Word Wrap on by Default” in the General tab.  Next, switch to the Highlighting tab and click “Modify”.  This will bring up another window with more Editor Options that can be turned on or off.  The most important thing for us is to be able to see the line numbers, since we’ll be working in the Code Editor tab.  Check the “Line Numbers in Gutter” box and click “OK”, then click “OK” again in the Preferences window.

If the line numbers don’t appear automatically appear, you can select View > Toggle Line Numbers or click the “Edit Display” icon ([edit-display-icon]) and select “Toggle Line Numbers”.

If the word wrap does not take effect, you can select View > Toggle Word Wrap or click the “Edit Display” icon and select “Toggle Word Wrap”.

Step 2 – Recreating the Index

You may notice that the page is broken into several div elements.  These are the various sections of our index page, and each div has a name to indicate what the section contains.  This is a perfect example of structural and semantic HTML.  It gives the page structure while letting you know what the contents are.

The Header Section

The first section we need to worry about is the “header” div.  This is the top-most portion that is viewable on our page, and contains the website title.  In our default layout, this text is “This is the header” in blue text, followed by a small paragraph “Usually some sort of description or tagline is placed here.”

The first thing we want to do is delete both of these lines.  You can highlight the entire block of code between the opening and closing div tags as seen in Fig. 3 (lines 45 &  46). 

Fig. 5 – Remove text in header

Inserting a New Header

Now that the header text is removed, we’ll start by adding a new heading for our page.  The h1 tag (1st-level heading) is often used for a website’s title.  In this case, we’ll insert the name of our website, “HTML for Beginners”.

Select Format > Header Sizes > Header Size 1, or click the “Fonts” icon ([fonts-icon]) on the toolbar and select “Header Sizes > Header Size 1” to automatically insert h1 tags.

With the cursor between the less-than (>) and greater-than (<) symbols, type “HTML for Beginners”.  If you give the Preview pane a second to update, you’ll now see this in place of the original heading.

Fig. 6 – New first-level Heading

Next, we’ll add a tagline.  After the last greater-than symbol on line 45, press “Enter” to start a new line of code.  Browsers ignore whitespace (multiple spaces, tabs, and new lines), so placing this on a new line is purely for readability later.  Click the “Paragraph” icon ([p-icon]) to add a paragraph.  You can type “An easy to follow guide to get you started”.

We could have just replaced the previous text that was already here, but this gives you an idea of creating your own elements.  Now you know how to insert paragraphs and headings.

The Content Section

The next important section on the page is the content.  This is the main focus of your site and should contain the most important information.

Again, we’ll remove all of the pre-inserted content and create our own.  Highlight lines 50-53 and press Delete to remove the code.  This time, instead of inserting the heading tags first, we’ll begin with plain text, then format it afterwards.  The point of this is to show you that the same results can be achieved several different ways.

Updates/Revisions Section

Type “Updates/Revisions” then hit your Enter key twice (to double-space the code and make it easier to read).  Next, type:

“The entire site is brand new, but as additional sections are added you can see what's new here. We'll also post the latest changes if code examples are updated or new explanations are given.

Revision 0.1 ”

(Note the blank line before Revision 0.1 and the space afterward.  The closer you can keep the body text to your output, the easier it will be to read when you have to go back and edit it later.)

Now your cursor should be on line 54, waiting for you to enter more text.  The next character on the page however, is not a standard keyboard character.  To display any special characters, you’ll need to insert an HTML entity.  Entities are special references to non-standard characters that may be used in word processing, such as dashes, ampersands (&), quotes (“), copyright (), less-than (<), and greater-than (>) symbols – just to name a few – and always begin with the & character and end with a semi-colon (;).  This is why the & has its own entity.  You can see most of the available entities if you click the Characters tab on the left.

The particular entity we need isn’t listed, so we’ll enter the name manually.  Type “&mdash;” to create a dash that’s as wide as the ‘m’ character for our font face.  Lastly, we’ll follow this with a space and the date in parenthesis.  You can have the HTML Editor automatically add the date for you by selecting Insert > Insert Date/Time, then choose the appropriate format.  Here, I’ve chosen the condensed format (MM/DD/YYYY).

To complete our first revision section, we’ll add the list of revisions.  Place each list item on a new line:

“Added background image in header.

Images have been added next to the headings on the index page (see above and below).

Headings on index have been changed to better reflect the content.

Minor style corrections (padding and colors).”

Now your cursor should be blinking at the end of line 59.

Formatting the Revisions Section

Highlight the text “Uploads/Revisions” on line 50 and select Format > Header Sizes > Header Size 2, or click the “Font Icon” as previously mentioned to set this as a second-level heading.  You should now see the h2 tags surrounding the text, and in the Preview pane the “Updates/Revisions” will look like the rest of the headings.

Next, we can highlight the paragraph on line 52 and use the Paragraph icon to surround it with paragraph tags (<p> </p>).  Another option here is to insert the tags through our Tags tab on the left.  You can find the tags in alphabetical order and double-click them to insert them into your code.

We’ll add another paragraph for line 54, as well as make the text bold by clicking the “Bold” icon ([b-icon]).  You can also select Format > Bold, or press Ctrl+B to bold the text.

The last items we need to format is the list.  Highlight lines 56-59 and click the “List” icon ([list-icon]) to start the List Wizard.  As with many other options, you can find the same function under the Insert > List menu option.  There are several different kinds of lists that you can create, but we’ll keep this list as a bulleted list.  Each of the list items have already been filled out in the Insert List window, but if you have other items they can be inserted here.  As before, each list item must be on its own line.  Click “OK” to have the HTML Editor create the list for you.

Now, we’ve created a 2nd-level heading, some paragraphs, formatted text, and created a list.  It seems like a lot now, but it was all done with just a few clicks.  In the next section, we’ll add another heading, paragraph, and some inline links.

Industry News Section

Add another empty line, and on line 63 insert another h2 tag.  This will be our “Industry News” section.  Add another paragraph on line 65 under the heading; remember to use the P-icon to add the necessary tags:

“HTML5 is on the way! Take a look at the Web Standards Project (WaSP) and World Wide Web Consortium (W3C) for more information. Many new semantic and structural tags are being implemented to make it easier to code with HTML.”

Next, to create links.  Highlight the text “WaSP” in parenthesis and select Insert > Link.  You can also click the Links icon ([link-icon]) and select “Link”.

The text “WaSP” has already been set as our link text, but when making your own links you can change this to anything you want.  The most important piece is the URL.  If you enter the wrong address here, the visitor will see an error message or will be taken to the wrong site.  Since we’ll be linking to a completely separate site, we have to insert the FULL address, “http://www.webstandards.org/”, as the URL.

The target option can be left at it’s default since we don’t want anything extra special to happen when the visitor clicks the link, other than take them to the page.  If you wanted to open a new window, override a frameset, or open the link in your own frame then you can specify it here.

We’ll also leave the title option blank, but it could help accessibility to add “Web Standards Project” here.  This will also provide a tooltip in the browsers when the visitor places their mouse over the link text.

Click “OK” to add this link to the text.

Next, we’ll add another link; this time to the World Wide Web Consortium.  Highlight the “W3C” text in parenthesis and click the Link icon again.  This time, enter “http://www.w3c.org/” as the URL.  Just like before, we’ll leave the rest of the options at their defaults.  Click “OK” again to add the new link.

Download this Website Section

Press “Enter” twice to start the next section on line 67.  Like before, we’ll add another 2nd-level heading: “Download this Website”.  On line 69, add the following paragraph:

“You can download the site files to practice with. Please read our policies for terms of use.”

Don’t worry about adding the links to this paragraph.  We just need this to flush out our page so it looks as close to the online version as possible.

Adding Images

So far we’ve only been adding text and formatting it somewhat.  That’s fine sometimes, but almost all websites you see have some sort of visual elements (images) that go along with the text.

The last element I’m going to describe is how to add images to any page.  Again, we’ll be working a little backward, going back up into the text to add the images to content that’s already there.  If you feel more comfortable adding images as you go along instead, feel free to do so.

If you’ve been looking at the downloaded files as we’re re-creating the pages, you’ve seen the small icons next to each of the headings.  The first image is named “Calendar-Month.png”.

Place your text cursor on line 50, between the greater-than symbol (>)  and the ‘U’ of “Update”.  This will ensure the image we insert is part of the heading and will be displayed on the same line.  Select Insert > Image, or click the “Image” icon ([image-icon]) to begin the Image Wizard.

In the Insert Image window, locate the “Calendar-Month.png” file on your hard drive.  You should see a preview of the image in the large window pane in the upper right.  The General tab gives you some options about the image.

The location of the image on your hard drive can be seen in the Image field (but it cannot be modified).  You can specify alternative text, in case the image is missing or cannot be displayed for any reason.  As an aside, alternative text is usually very helpful not only with accessibility but in indexing your page with search engines, and should be provided at almost every opportunity.  In this example, we’ll just use “calendar icon” as the alt text.

The align option lets you specify how text on the same line should be lined up with the edge of the image.  There are several different options to choose from, but we’ll keep the default (blank) option.

The size is also automatically added, which allows browsers to set aside areas of the display as your content is being downloaded.  Although not necessary, it can give the browser and your readers an idea of the image’s size.  All icons used throughout the website are either 32x32 or 16x16 pixels (so they download very fast and take up little space).  You can change the image size manually (even if it wasn’t originally that size), but keep in mind that this can cause distortion, so your images should be saved at the exact dimensions you want them to display before adding them to your page as often as possible.

The last option allows you to specify an address that will load when the image is clicked.  This is what most people refer to when the want to create a “button” for their pages.  Just like other links, if you’re linking to a completely separate website, you need to specify the full URL.  We’ll leave this empty since the actual image doesn’t need to link anywhere.  Click “OK” to add the image onto the page.

Let’s go ahead and add the image next to the next heading.  Place the cursor next to the ‘I’ in “Industry” on line 63 and click the Image icon again.  This time, choose “Industry News.png” file and click “OK” to add it.

Lastly, we’ll add the image next to the “Download” heading.  Just like the other two, place the cursor before the ‘D’ and click the Image icon.  This image is named “Download.png”.

The Navigation Section

The next section within the HTML code is a div for the website navigation.  It doesn’t necessarily need a header (if we do a good job) as most people will recognize this as a navigation menu.  For that reason, we can completely delete line 73.

Just from looking at the current code, you may notice that it looks a lot like the list we added in the “Updates/Revisions” section earlier.  This is because the most logical structure for a menu is a list.  If you really think about it, a menu is just a list of links that are displayed horizontally or vertically.

You’ve already added a list, as well as linked text to other sites, so I won’t make you recreate the entire structure from scratch.  Instead, we’ll edit what’s provided in the layout for us.

Place the cursor between the “ and “ characters of the href attribute on line 74.  This is where the URL for our links can be inserted.  Since the menu will be for our own site, we’ll use what’s called “relative paths”.  This means the files will be stored on the same computer (server) and so we don’t need to give the full address.  We just need to tell the browser how to get there from here.

Because the rest of our pages will be saved in the same folder, we can just type out the name of the file we expect to save later.  It can be a bit confusing, which is where all the planning you did earlier comes in.  The first link in our menu will be to the Home page (what we’re working on), which should be named “index.html”.  Enter this as the href attribute value and change “Navigation 1” to “Home”.

Our second link will be “Getting Started” so you can remove the “Navigation 2” text and replace it with the proper link text.  The filename we want this to link to will be “getting-started.html”, so this should be entered between the “ and “ characters of the href attribute on line 75.  Follow the same procedure for all the various links in the menu:

· Basic Elements = “structural-elements.html”

· Formatting = “headings.html”

· Advanced Structures = “lists.html”

· Tag List = “tags.html”

The Extra Section

Once we finish with the menu, we can move on to the Extra div.  This section contains any special information we want to provide for visitors, and in the case of HTML for Beginners I wanted to give them products to make coding easier.

The heading for this has been changed to “Tools” (instead of “Extra Stuff Goes Here”), so just like in the Content section, you can edit the h2 tags.  The paragraph underneath states

Get started learning HTML the right way. Sure you can use Notepad or any regular text editor, but that's boring. Use any of these tools from CoffeeCup Software to get your site up and running quickly:

and the “CoffeeCup Software” text links to http://www.coffeecup.com/.

After this paragraph, I’ve added a list of applications I think may help in the future.  Click the List icon to open the Insert List dialog box again.  Add CoffeeCup HTML Editor 2007, DirectFTP, Google Sitemapper, Image Mapper, Website Color Schemer, Stylesheet Maker, PixConverter, Website Font, and Web Form Builder each on their own lines.  The other options can all be left at their defaults, then click “OK”.

Once the list is created, you can highlight each list item (the text between the <li> and </li> tags) and create links to the product pages for each application:

· http://www.coffeecup.com/html-editor/

· http://www.coffeecup.com/direct-ftp/

· http://www.coffeecup.com/google-sitemapper/

· http://www.coffeecup.com/image-mapper/

· http://www.coffeecup.com/color-schemer/

· http://www.coffeecup.com/stylesheet-maker/

· http://www.coffeecup.com/pixconverter/

· http://www.coffeecup.com/website-font/

· http://www.coffeecup.com/form-builder/

The Footer Section

The footer div contains yet another linked-list for navigation.  I’ll spare you most of the particulars and just provide the link text and URLs that should be used

· About = “about.html”

· Copyright = “copyright.html”

· Download = “download.html”

· Contact = “contact.html”

· Sitemap = “sitemap.html”

· CoffeeCup Software = “http://www.coffeecup.com/”

The paragraph under this linked-list simply contains a condensed copyright statement about when the website was created.  You can use the Characters tab to insert the copyright symbol, or type “&copy;” followed by “ Copyright “ and another em-dash (like the Revision statement) and the year.  Remember, the entity for an em-dash is “&mdash;”.

Overview

Let’s recap what has been accomplished so far.  You’ve added heading sizes 1 and 2, images, paragraphs, links, lists, and special characters.  All on just the homepage for the website.  That’s quite a bit for any beginner, but as you can see they all form the basis of a great site, but we’re not done yet.  If you remember at the beginning we talked about using two separate layouts (one for the exterior pages, and another for interior pages).  In the next section, we’ll discuss how to recreate an interior page.

Step 3 – Recreating the Getting Started Page

Each of the interior pages (those with actual content about writing HTML) will be using a different layout than the index page.  Select File > New from Layout, then choose “two_columns_liquid,_side_fixed(n.24).html” and click “Open”.  Now you should have two open file tabs at the bottom of the HTML Editor window (Untitled1.html* and Untitled2.html*).

Copying the Header, Footer, and Navigation

Since these three areas will be identical on every page, we can copy the same content every time.

Switch to the Untitled1.html file tab and highlight lines 44-47.  We’ll be copying over the entire div to make sure nothing is missed.  Select Edit > Copy, or press Ctrl+C, to copy this text to your system’s clipboard.  Next, switch back to the Untitled2.html file tab and highlight lines 44-47 here as well.  Select Edit > Paste, or press Ctrl+V, to paste the header into the new layout.

Next, we’ll copy the footer over.  Again, switch to Untitled1.html and highlight lines 97-107 (the entire footer div) and press Ctrl+C to copy.  Click the Untitled2.html tab to switch back and highlight lines 73-83.  Press Ctrl+V to paste, or select Edit > Paste.

Lastly, we’ll copy over the navigation.  In Untitled1.html, highlight lines 72-81 and copy the code to your clipboard.  Switch over to Untitled2.html and highlight lines 56-66 and press Ctrl+V to paste the navigation div.

Now we have the three basic sections of our page.  The only thing left to differentiate this from our homepage is the content and extra sections.

The Content Section

Each interior page uses the h2 to denote this particular page’s title (and location) within the site structure.  Since we’ll be recreating the Getting Started page, let’s insert this heading.

You can highlight the text between the h2 tags on line 50, then click the “Insert Image” icon (or select Insert > Image) and locate “The Internet.png”.  Enter “internet icon” as the alternative text and click “OK” to insert the image.  Next, type “Getting Started” (also within the h2 tags) to add the heading.

Underneath this, on line 51, we have our first paragraph.  It’s simply the single sentence, “Knowing what a site is and how they work (even if just vaguely) will give you a leg up on someone who's trying to wing it.”

After this, we can hit the Enter key a few times to add more spacing within our code (for readability later).  Now your cursor should be on line 53.  Since you’re already familiar with all the important aspects of creating pages, I won’t bore you with the details again.  Each question is a 3rd-level heading, followed by a paragraph answering that particular question.

A tip on code indenting: I find it easy to indent the div tags (to make it easy to find each section) but the code contents of the divs can be left aligned.  Having the code flushed to the left edge of the window make it easier to read and edit later.  It feels more like reading the actual page than blocks of code.  I also find it easier to read if a blank line is left between headings and the paragraph preceding it (like we did between the h2 and paragraph tags).

Once you copy the contents of the Getting Started file, your cursor should be around line 70.  Now we can add the backward and forward links to each page.  The arrows are special characters known as “left-angle quotes” and “right-angle quotes”, and can be found in the Characters tab.  The actual entities are “&laquo;” and “&raquo;” respectively.  Select Insert > Link, then in the Link Text box enter “&laquo;…Home”.  The page this will link to will be named “index.html” (as all homepages should be).  Add a space and insert another link, this one to “coding-terms.html” with the text “Coding Terms…&raquo;”.

This completes our content section of the page.

The Extra Section

Now that we have the content for the page setup, we can start adding any extra information we want to give the visitors.  The heading for this section would be “Advanced Tips” on line 84.

We have two paragraphs in this section, each only a few sentences.  Because this section is much thinner than the content, a few sentences can seem like a large paragraph.

Lastly, there is a 3rd-level heading for various hosting providers.  Under this heading is a linked-list so visitors can find more information.  The links are as follows:

· http://www.lunarpages.com/

· http://www.bluedomino.com/

· http://www.1and1.com/

· http://www.godaddy.com/

· http://www.sharkspace.com/

Step 4 – Styling the Website

This step will be a crash course in Cascading Stylesheets (CSS).  CSS is a method of creating styles that pages conform to, which can be linked from any page.  If a page calls a stylesheet, the styles specified within are automatically used to define the look of the page’s html code.

All of the layouts have their styles written in the head (along with the title and meta information), which are known as embedded styles.  You can see these beginning on line 7 of both pages we’ve created so far.

Most of the page styles can be left alone (for our purposes), but the color scheme is a little bland.  We’ll be changing this to a more “serious” look using browns, olives, tans, and a very “earthy” color scheme.  You can view all the colors we’ve chosen at http://beta.dailycolorscheme.com/archive/2006/09/08

Each color has a hex-value associated with it (also available at the above address) that we’ll be using:

· #4b4c3c

· #57470c

· #968148

· #9c9a69

· #c9c9b1

· #ebe1c6

· #f2f2e8

The Header Section Colors

The first section we’ll re-style is the header section at the top of the page.  This is the light-gray area across the top that has our website title “HTML for Beginners” and tagline.  You can see the styles associated with this particular section on lines 15-18 (Each particular section is separated by a CSS comment).

A little tip on CSS – the ‘#’ character within styles denotes an id name.  The “#header” section corresponds to the header div id.  The same is true for “#wrapper”, “#content”, “#navigation”, “#extra”, etc.  We’ll see more uses of this later.

To change the background color of the header section from this light-gray to the brown used on our live version, change the “eee” to “57470c” on line 16.  Just like when we were editing the text, if you give the Preview pane at the bottom of the HTML Editor time to catch up, you’ll see the new color automatically applied.

This brown is decent, but we can’t see the blue text above it anymore so that needs to change as well.  To provide contrast, we’ll select one of the lighter colors (but not too light) on this dark background.  The middle “khaki” color looks pretty good for this.  On line 17, change “004b6f” to “c9c9b1”.

Lastly, we’ll change the color of the tagline paragraph.  This needs to be subtler than the headline, so we’ll make it slightly darker, but not so dark that it blends into the background color.  “9c9a69” seems like a good choice for it, so we can replace “666” on line 18 with this new color.

That’s how easy it is to change the look of an entire section with a few code edits.  Next, we’ll work on the footer.

The Footer Section Colors

Now that the top-most viewable section of the site is styled, we can move down the page to the footer to get the framework done.  Most footers are either very dark or very light, the purpose being to downplay any text or content contained therein.  You don’t necessarily want to hide it, but consider this much like fine print.  It’s there, but only if you look for it.

Our footer contains links to other important top-level pages of our site, such as the copyright notice, an about page, and the sitemap.  This means we don’t want to make it hard to find, but it does need to have it’s own identity on the page to differentiate the footer from the rest of the content.

The default color scheme is using a very dark footer, and our new scheme has a very similar hue we can use: “#4b4c3c”.

The comment for the footer section is actually on line 30, towards the end of the line.  Place your cursor just before the ‘/’ character and press enter twice to separate this section.  Now “/*Footer*/” should be on line 32.

We can change the background color on line 33, from “333” to “4b4c3c”.  If you scroll down the preview pane, you can see the new color automatically applied.  The footer does look nice, but the off-white links blend in too much with the paragraph beneath them.  We can change this color on line 34 from “eee” to “968148”.  The links are almost the same color as the header background, but not quite as dark, which helps to relate that they are indeed links to other pages.

The Navigation and Extra Section Backgrounds

The navigation and extra sections don’t have a background color by default; they just sort of blend into the page.  This may be fine for some sites, but these sections have specific purposes for us.  We’ll want to separate the navigation from the rest of the page since there are so many lists of links.  The Extra section contains advanced tips on most pages, so we’ll definitely want to differentiate it somehow.

We can add a background color to the navigation section on line 21.  If you look at the header and footer sections, you should see that the specific style property looks like: “background: #hex-value;”.  (Each property is separated by a semicolon (;)  character, with the last property’s semicolon being optional.  Some coders prefer leaving it, in case you need to come back later and add more styles).

Just like the header and footer section, we’ll place the background property first.  Place your cursor on line 21, just before the ‘b’ in “border” and type “background: #f2f2e8; ” (remember the semicolon and place a space to separate the different properties).

The same can be done for the Extra section, on line 23.  Place the cursor before the ‘b’ in “border” and type “background: #ebe1c6; “.

Other Custom Styles

Now that we have most of the styles setup, we can begin adding our own flair to the page.  One of the most common techniques designers use to add interactivity to pages through CSS is to change the color of text links when the cursor is placed over them.  Changing this hover color helps signify to the visitor that it is in fact a clickable link item.

We’ll go ahead and use this trick in our website as well, changing the default green color to the dark brown used for the header background.  To help keep these styles separate from the rest of the page, we’ll add another section.  Place your cursor at the end of line 37 and press “Enter” twice, then type “/*Custom Styles*/” to add a CSS comment.

Press “Enter” yet again to place the cursor on line 40 now.  The style we want to set will apply to any anchor elements (a), and will use the :hover pseudo-class.  Type “a:hover { color: #57470c; }” .  Now whenever a visitor to the page places their mouse over any link it will turn brown instead of green.

Background Images

Next, we’ll apply a background image to one of the sections (in this case the header section).  Press “Enter” to start a new line of code on line 41.  We have to specify that we only want this to apply to the header div, so type “#header {  }“.  Anything within the ‘{‘ and ‘}’ characters will be our style properties.

So far we’ve seen “background” used as a property, but this is actually shorthand used to combine several rules at once.  To make it easier to understand, we can break them down into “background-color” (which we’ve already set), “background-image”, “background-repeat”, “background-attachment”, and “background-position”.

To set the background image, type “background-image: url(); “ and insert the image’s filename or file path between the parentheses.  In our case, the image is named “title2.jpg” so the property will look like this: “background-image: url(title2.jpg); “.

Normally, the background will automatically tile across, then down the element unless you tell it not to.  You can even specify it to only repeat in certain directions (x or y).  It doesn’t matter if our background tiles down, but we only want to see it once across the header.  To make it really easy, the background image was made larger than the section height, so we can set it to not repeat at all.  With your cursor still inside the parentheses on line 41, type “background-repeat: no-repeat; “.

Lastly, we’ll set the position of the background.  By default, the image aligns with the top-left corner of the element, but that doesn’t give us a good view of the blurry code.  Plus, it interferes with the heading text and tagline, distracting from their importance; so let’s move the background to the right hand side.

You can use left, center, right, top, center, bottom, percentage values, or even pixel values to move the image around.  You can even use two values, one to move left-right and another to move up-down.  Feel free to experiment here, but I’ve found 100% (to flush the right edge) and 35% to provide the best results.

List Style Images

You may have noticed that many of the lists we have on the live site don’t use standard bullets, such as the navigation list and CoffeeCup Software Tools.  We can change the list style properties using CSS as well.

Begin a new line after the custom header styles and type “#navigation li {   }” to specify the list items inside the navigation section.  Within the braces, we’ll be using the “list-style-image” property to change the standard bullets to any image we want.  For our website, this will be “arrow.gif” and “arrowdark.gif”.  The rule would look like “list-style-image: url(arrow.gif); ”.

To change the arrow color (along with the link color) we can use the :hover pseudo-class just like we did earlier with the anchor element.  The trick here is to be more specific about what elements and rules we want to apply.  On a new line (line 43) type “#navigation li:hover {   }”.  Now we’re saying that no matter what the regular list item style is, if the mouse is hovering over it, use this new style instead.  Again, we can use the “list-style-image” property to change the bullet image, this time to “arrowdark.gif”.  It should look something like “#navigation li:hover { list-style-image: url(arrowdark.gif); }”.

Custom Classes

We’re almost done with creating the styles.  Lastly, I want to show you how to create custom classes that can be reused throughout the entire website, no matter what section or element they are applied to.

You may have noticed that there is only one “header” section, one “footer” section, one “content” section, etc.  These are special ids given to div elements throughout the page to provide structure, and because ids serve this specific purpose they must be unique.  In contrast, you can create classes that can be applied to any element and used as many times throughout the site as you’d like.  Classes are more like the brushes a painter would choose from, while div ids are the separate canvases that make up a mural.

We’ll apply a special class to the list of software on the home page and use the list-style-image property discussed above to change the bullets to coffee cup icons.

Locate the ul tag that begins the list of software, on line 93.  Place your cursor just before the ‘>’ character and add the class attribute.  Within the quotes name the class “software”, so now the line looks like “<ul class=”software”>”.

That won’t do anything by itself, but now we have attached the class to a specific element.  We can go back up to the end of line 43 and press “Enter” to start a new line of code.  All classes begin with a period (.) character before any style rules are specified.  Type “.software” and add a list style image using the “coffeecup.png” file:

.software { list-style-image: url(coffeecup.png); }

Overview

With just a brief run through CSS, you’ve seen how to change colors, add background colors and images, and change list syles.  Once you’ve setup the styles on one page, they can be copied throughout the entire website.  Highlight lines 7-45 (the entire style block) and copy them to your clipboard.  Switch over to the other page and highlight the style block here (lines 7-36) then press Ctrl+V to paste the styles.

Step 5 – Saving, Testing, and Uploading

You can save the two pages we’ve been working on now.  It doesn’t matter where on your hard drive that both files are saved, as long as they’re saved in the same location.  The first page, “Untitled1.html” should be saved as “index.html”.

Select File > Save As… or click the “File Save” icon ([save-icon]) and select “Save As”.  The HTML Editor provides a default folder where you can save all your files into, called “Working”, so it would be best to keep them within this folder.  Make sure the “Save In” location states “Working” as the directory where the files are being saved.  In the File Name field, type “index” or “index.html” (the HTML Editor will automatically add the ‘.html’ extension if it’s not present).  The second page should be named “server-terms.html”, so you can perform the same process for “Untitled2.html”.

Testing in Different Browsers

Once your files are saved to the hard drive, it’s best to test the page in as many browsers as possible (or at least the browsers you expect your visitors to be using).  The browser market is currently divided between Internet Explorer 6, Internet Explorer 7, Firefox, Opera, and Safari.  There are several other browsers available as well, but even testing in just IE and Firefox will cover most of the visitors you can expect.

The reason testing is so important is not just for functionality, but for aesthetics.  Each browser renders styles and code slightly different from each other, or even different versions of the same browser.  IE 7 made significant improvements from IE 6, but both still render differently than Firefox or Safari.  You can download as many browsers as you’d like from each manufacturer’s website, and only one will be used for your everyday browsing purposes.  This is your default browser and can be whatever choice you prefer to use.

Our Preview tab (the pane we’ve been seeing at the bottom of the application window) uses Internet Explorer 7’s rendering engine, so it’s a good approximation of what you’ll see if the page were visited in IE.  If you have installed multiple browsers, you can select Tools, then click one of the “Test With Additional Browser” options to specify which browser to test with.  Simply locate the exe file on your hard drive that launches the browser (C:\Program Files\Internet Explorer\iexplorer.exe) and it will automatically be associated with the menu options.  You can also find it under the “Test in Browser” icon ([test-icon]).

There are special IE-only comments that will only be processed if the visitor is using Internet Explorer.  This comes in handy, because if you test the pages so far in Firefox and IE you’ll notice the background colors are flush in Firefox, but not IE.  We can find these special comments on lines 46-50.  If we change the margin-top attribute to only apply to the content section, and set the navigation and extra sections to have a 20px padding instead, all the headings will line up and have the backgrounds flush in all browsers.

The code should look similar to:

#content { margin-top: 20px; }

#navigation, #extra { padding-top: 20px; }

Once you’ve tested the pages in as many browsers as possible and you feel comfortable with the results, save them again.  Now, you’re ready to upload.

Uploading Your Website

There are two functions you can use to upload your website to the server.  Select File > Upload File to Server > Add or Edit Servers.  Create a new profile using the information provided by your host.  Once completed, you can right-click any files in the Files tab and select “Upload File to Server” to upload your files.

The HTML Editor is also bundled with our FreeFTP application.  Select Tools > Applications > Free Stand-Alone FTP Client.  When prompted to locate an application, search for the exe at C:\Program Files\CoffeeCup Software\FreeFTP\freeftp.exe.  Once this is selected, Free FTP will launch automatically.

Click the Servers button in the upper left corner to bring up the Server Profiles window.  If you’ve used any of our other applications, any profiles you’ve already setup will be listed on the left.  If you don’t have a profile yet, you can press the “Add” button ([add-button]) to begin the Server Profile Wizard.  Fill out each field with the information provided by your server and click “Finish” when you’re done.  Click “Connect” to actually connect with the server.

The left pane displays the files on your local computer, while the right pane shows any files already on the server.  You can navigate to the “Working” directory at C:\Program Files\CoffeeCup Software\Working\ on the left to find your website files.  Drag them over to the right window pane to begin the upload process.  You can also select files and press the “Upload” button ([upload-button]) to start uploading files to your server.

Conclusion

Now you’ve created a website, tested it, and uploaded files to your server.  That’s all there is to getting your presence online.  You can refer back to this tutorial anytime you need a refresher course, or create the same pages as many times as you’d like (just to make sure you have the process down).  If you have questions about any step along the way, contact our support team at http://care.coffeecup.com/support/.

